Author Archives: papadiddydoo

google api client no such file to load

Getting the following error when running annotate for my models

…/activesupport-4.2.6/lib/active_support/dependencies.rb:274:in `require’: No such file to load — google/api_client (LoadError)

Try downgrading your google-api-client to a version below 0.9, namely…

Modify your Gemfile to have this line instead of what is there now for the google api gem

gem ‘google-api-client’, ‘<0.9’

rails console hangs

“rails c” hangs with no error messages and no response.

solution: stop spring using the following command
“spring stop” or “bin/spring stop”

spring will automatically start back up when you run the rails c command.

zsh: non-standard shell error

Getting the following error when trying to change your mac terminal to use zsh?

chsh: /usr/local/bin/zsh: non-standard shell

All you need to do to fix this is to add the zshell path ( /usr/local/bin/zsh) to your /etc/shells file.

sudo vim /etc/shells

I added  /usr/local/bin/zsh to the end of the file.

 

 

 

 

Installing TrueCrypt7.1a for OSX Yosemite

Open the .dmg

You’ll find the .mpkg. Right*click and “Show Package Contents

Open Contents Dir

Open Packages Dir

Install each of the 4 packages in this order:
1. OSXFUSECore.pkg,
2. OSXFUSEMacFUSE.pkg,
3. MacFUSE.pkg,
4. TrueCrypt.pkg

Taken from the source listed below.  They also have other ways of accomplishing the same thing, but I found the way listed above to be the easiest and least technical

Source: https://lazymind.me/2014/10/install-truecrypt-on-mac-osx-yosemite-10-10/

GPG signature verification failed when updating rvm

When updating rvm getting error message like the following.

GPG signature verification failed for '/usr/local/rvm/archives/rvm-1.26.5.tgz' - 'https://github.com/wayneeseguin/rvm/releases/download/1.26.5/1.26.5.tar.gz.asc'!
try downloading the signatures:

Type the following in terminal to fix it.
sudo gpg --keyserver hkp://keys.gnupg.net --recv-keys D39DC0E3